Print Page | Close Window

AccuTerm Platform Settings Missing

Printed From: Rocket Software
Category: AccuTerm Knowledge Base (read only)
Forum Name: File Transfer
Forum Description: Help with uploading & downloading database and document files
URL: https://forum.asent.com/forum_posts.asp?TID=2692
Printed Date: January 31 2023 at 12:23pm
Software Version: Web Wiz Forums 12.03 - http://www.webwizforums.com


Topic: AccuTerm Platform Settings Missing
Posted By: Colvy
Subject: AccuTerm Platform Settings Missing
Date Posted: July 26 2018 at 1:41pm

I'm using UniVerse version 11.2.5 on Linux using AccuTerm 7.

Step #1:

I run a simple program AAA from TCL that includes the following lines of code:
EXECUTE "SETPTR 0,132,66,0,0,0,AT ARLING,NFMT,NHEAD,BRIEF,RETAIN,INFORM"
PRINTER ON
EXECUTE 'LIST MOVEMENT.CODES SAMPLE DESCRIPTION LPTR'
PRINTER OFF
STOP

If the FTVSINF program is launched at this time I get the following results:

PLATFORM = [3]

PRODUCT = [4]

Release = [7.301]

CAPABILITIES = [AKFJMPQTVYCDUEILRSOXGH]

SERVICES = [0abg]

SERIALNUM = [######]

LICENSE = [2]

USER = [######, #######, ############]

Step #2:

The SETPTR command uses AT ARLING. It looks at /usr/spool/uv/sp.config and finds that ARLING is associated with the /usr/spool/uv/lpdrvarl script.

Step #3:
The lpdrvarl script contains the following logic:
#!/bin/bash
cd /u2/TESTIT/TEST.AA
echo $2 | /u1/uv/bin/uvsh "BBB"

Step #4:
When the BBB program is ran it is missing the original environmental variables that I had originally in Step #1. I was hoping to call FTSEND in this program, but it doesn't think that AccuTerm is running any more.  At this point FTVSINF gives the following results:

PLATFORM = [0]

PRODUCT = [0]

Release = [0]

CAPABILITIES = []

SERVICES = []

SERIALNUM = [0]

LICENSE = [0]

USER = []

How can I get it to reset the AccuTerm system variables so I can run FTSEND?  Dead

Once all four steps are completely done, then it gets back to normal and knows that it using AccuTerm again.

Thanks,

Jeff



-------------
Colvy



Replies:
Posted By: Shrek59
Date Posted: July 26 2018 at 7:58pm
Your basic problem here is that program BBB is running in a totally separate instance of UV. It knows nothing about AccuTerm - in fact nothing about any terminal emulator, because it isn't connected to a terminal!

It seems that you are trying to create some report output, and then do something with it. Try this instead:

OPEN '&HOLD&' TO fp.hold ELSE STOP
epoch = SYSTEM(99)
EXECUTE \SETPTR 127,2000,30000,0,0,3,AS \:epoch:\,NOFMT,BRIEF\
cmd = 'LIST MOVEMENT.CODES SAMPLE DESCRIPTION LPTR 127'
EXECUTE cmd CAPTURING junk
READ output FROM fp.hold,epoch ELSE output = ''
* Now do something with the output
This defines a "printer" to save the output to the &HOLD& file. This is just an O/S level folder. You can then do what you want with the output stored there.

Now call FTSEND from within your current process. In fact, you probably don't need to read the output at all - just supply the filename (&HOLD&) and @ID (epoch).

Hope this helps,

Brian



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.03 - http://www.webwizforums.com
Copyright ©2001-2019 Web Wiz Ltd. - https://www.webwiz.net