AccuTerm by Zumasys Homepage
Forum Home Forum Home > AccuTerm > Green Screen
  New Posts New Posts RSS Feed - Term type 'Linux Console'
  FAQ FAQ  Forum Search   Register Register  Login Login

Term type 'Linux Console'

 Post Reply Post Reply
Author
Message
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Topic: Term type 'Linux Console'
    Posted: August 08 2018 at 9:15am
I use AccuTerm a lot for SSH into various Linux systems with no MV involved at all.

I'd like to get more control over screen formatting at shell # and $. I'm working with both Ubuntu and CentOS.

Right now, as an example, here is what I see:

      rm: remove regular file âmaillogâ?
      
      [root@callisto log]# echo $TERM
      linux

So with the AccuTerm Linux Console term type I'm still seeing control characters. Is there a better setting for pairing Linux and AccuTerm term types?

Thanks!
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
PSchellenbach View Drop Down
Admin Group
Admin Group

Moderator

Joined: December 15 2003
Location: United States
Status: Offline
Points: 2117
Post Options Post Options   Thanks (0) Thanks(0)   Quote PSchellenbach Quote  Post ReplyReply Direct Link To This Post Posted: August 08 2018 at 9:40am
Hi Tony -

I believe the funny characters you see at shell prompt (and when executing many Linux commands) are due to different character set encoding on the server (probably UTF-8) and AccuTerm (probably ISO-Latin-1). If you change the character set in AccuTerm to UTF-8, everything will probably work Linux-wise, but might not play nicely with MV apps not using UTF-8. Or change your Linux character encoding to Latin-1: export LANG=en_US.ISO-8859-1.

Thanks,

Pete

Back to Top
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Posted: August 08 2018 at 5:16pm
UTF-8 did it. Thanks Pete!
Of course I also use Linux+MV in other systems. A long time ago I was thinking about writing a script that would toggle all required settings as I move between MV and the OS. One of these days soon I think I'll need to do that. :)

Best to ya bud!
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Posted: November 05 2018 at 11:04am
Follow-up: Setting Host Terminal Type to 'linux' is also key here. I have another .atcf using UTF-8 that didn't have this term type, and was still getting the raw characters rather than desired graphical symbols.
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.