Zumasys Homepage
Forum Home Forum Home > AccuTerm > File Transfer
  New Posts New Posts RSS Feed - "FTSEND requires Accuterm" while being run from it
  FAQ FAQ  Forum Search   Register Register  Login Login

"FTSEND requires Accuterm" while being run from it

 Post Reply Post Reply
Author
Message
sbhenkel View Drop Down
Newbie
Newbie


Joined: March 03 2017
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote sbhenkel Quote  Post ReplyReply Direct Link To This Post Topic: "FTSEND requires Accuterm" while being run from it
    Posted: October 30 2017 at 8:21am
I am running FTSEND from a QM system using AccuTerm.  Periodically I get the message "FTSEND requires AccuTerm to run!".  I looked at a few other posts and saw that there's a subroutine that it calls to determine if you are actually using AccuTerm.  Could this be some kind of timing issue?  Is there any way to find out and possibly compensate?
Back to Top
pickteam View Drop Down
Newbie
Newbie


Joined: December 20 2004
Location: United States
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote pickteam Quote  Post ReplyReply Direct Link To This Post Posted: March 13 2018 at 8:18am
Yes, I'm seeing more and more of this error. It appears that one of the FININT programs executes an escape sequence that returns Accuterm information to the program. Periodically, there is some sort of timing issue and the string doesn't come back, which causes an error message in FTD or whatever you're trying to do.

To make matters worse, the Accuterm information string then will suddenly appear in the input buffer and also trash the next command.

Since none of us have had a dumb terminal in years, it would seem that registered users could be offered a way around this annoyance. 
Douglas Tatelman
Back to Top
sbhenkel View Drop Down
Newbie
Newbie


Joined: March 03 2017
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote sbhenkel Quote  Post ReplyReply Direct Link To This Post Posted: May 02 2019 at 8:50pm
I finally found what was causing the error for me.  I thought I would share it in case it works for others.  As mentioned earlier, one of the AccuTerm programs executes an Escape sequence.  Then there's an input statement that captures the output of the sequence.  In my case I traced it back to the fact that I had left the PRINTER ON, not literally of course.  In other words I needed to do a PRINTER OFF command before the program that would ultimately call FTSEND.  As soon as I did the problem was solved.  With the PRINTER ON the result of the Escape sequence was just going to a spooler hold file.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.