Zumasys Homepage
Forum Home Forum Home > AccuTerm > Installation & Setup
  New Posts New Posts RSS Feed - Enable app account with ATGUI?
  FAQ FAQ  Forum Search   Register Register  Login Login

Enable app account with ATGUI?

 Post Reply Post Reply
Author
Message
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 105
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Topic: Enable app account with ATGUI?
    Posted: December 05 2019 at 11:48am
I'm probably going to be embarrassed with a simple solution, but I'll take that in stride. I don't recall how to enable an application account to use ATGUI. FTSETUP doesn't do it.

v7.2

Thanks!
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
Shrek59 View Drop Down
Senior Member
Senior Member


Joined: December 04 2006
Location: New Zealand
Status: Offline
Points: 196
Post Options Post Options   Thanks (0) Thanks(0)   Quote Shrek59 Quote  Post ReplyReply Direct Link To This Post Posted: December 05 2019 at 12:06pm
Hi Tony,

FTSETUP is *supposed* to do it. In my recent experience on UV, I find that the pointers that FTSETUP puts in the account don't really work. Therefore, in the target account, I will do things like:

  CATALOG FTBP *

and the same for the other AccuTerm program files. Everything works fine after that!

Cheers,

Brian
Back to Top
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 105
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Posted: December 05 2019 at 12:17pm
That sounds like something that requires Zattention, or at least Zconfirmation. And perhaps a note if this is different in v8.
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
PSchellenbach View Drop Down
Admin Group
Admin Group

Moderator

Joined: December 15 2003
Location: United States
Status: Offline
Points: 2125
Post Options Post Options   Thanks (0) Thanks(0)   Quote PSchellenbach Quote  Post ReplyReply Direct Link To This Post Posted: December 12 2019 at 6:13pm
Tony - as Brian said, FTSETUP should enable the target account to use any of the AccuTerm program libraries that are installed in the ACCUTERM account: FTBP, OBJBP, GUIBP, SUIBP. If that is not working please open a ticket. FTSETUP on jBASE is tricky because of the nature of jBASE. You need to log out of the target account and log back in for those programs to be recognized. Logging back in adds their directories to the PATH and LD_LIBRARY_PATH variables.

Brian - what is the problem that you have seen with the catalog pointers in UniVerse? Is your ACCUTERM account up to date? Since 2007, AccuTerm uses the LOCAL COMPLETE option when catalogging programs in the ACCUTERM account for Universe, so that when the catalog items are copied to a different VOC they have the full path back to the ACCUTERM account.

Thanks, Pete

Back to Top
Shrek59 View Drop Down
Senior Member
Senior Member


Joined: December 04 2006
Location: New Zealand
Status: Offline
Points: 196
Post Options Post Options   Thanks (0) Thanks(0)   Quote Shrek59 Quote  Post ReplyReply Direct Link To This Post Posted: December 14 2019 at 9:38pm
Hi Pete,

Here is an example using QM (Linux 64 bit, non ECS) and AccuTerm 8.

CT VOC MASTER.LOGIN (in QMSYS account)
1: PA
2: DATE.FORMAT ON
3: PTERM CASE NOINVERT
4: PTERM BINARY ON

CREATE.ACCOUNT QMTEST /home/brian/qm/qmtest
Create new directory for account (Y/N)? Y
Creating VOC...
Creating $HOLD...
Creating $COMO...
Creating $SAVEDLISTS...
Creating private catalogue directory...
Adding to register of accounts...

Create a LOGIN item in the new account:

CT VOC LOGIN
1: PA
2: OPTION PICK
3: OPTION CATALOGUE.LOCAL
4: OPTION LOCAL.CAT.RELATIVE
5: OPTION NO.DATE.WRAPPING
6: OPTION PICK.IMPLIED.EQ

OPTION
Encoded: X243252713111E06131

LOGTO ACCUTERM
FTSETUP
Enter option (1-7) or X to exit: 1

This option will create the necessary file pointers
and copy the cataloged program items to the account
you specify.

Enter the name of the account you want to set up: QMTEST

Setup of QMTEST complete.

LOGTO QMTEST
WED VOC LOGIN
Cannot load WED - FTBP.OUT/WED not found
Cannot load FTINITEX - FTBP.OUT/FTINITEX not found
Cannot load FTVSINF - FTBP.OUT/FTVSINF not found
Cannot load FTVERSN - FTBP.OUT/FTVERSN not found
Cannot load FTPGMDIR - FTBP.OUT/FTPGMDIR not found
Cannot load FTCMDLN - FTBP.OUT/FTCMDLN not found

Cannot load FTSVRSUB - FTBP.OUT/FTSVRSUB not found
Cannot load FTCLISVR - FTBP.OUT/FTCLISVR not found
Cannot load FTDECODE - FTBP.OUT/FTDECODE not found
Cannot load FTFSI - FTBP.OUT/FTFSI not found
Cannot load FTENCODE - FTBP.OUT/FTENCODE not found

BUT ... WED actually DOES start, and DOES display the item! If you repeat the command (.X), same thing happens.

CT VOC FTBP FTBP.OUT WED
VOC FTBP
1: Q
2: ACCUTERM
3: FTBP

VOC FTBP.OUT
1: Q
2: ACCUTERM
3: FTBP.OUT

VOC WED
1: V
2: CS
3: FTBP.OUT/WED


Now, we recatalog everything in FTBP. Note use of NO.QUERY - otherwise you get prompted for every item (that the catalog information is different).

CATALOG FTBP * NO.QUERY
FTOPTION added to local catalogue
PHIACCOUNTSETUP added to local catalogue
FTMODE added to local catalogue
FTWIZ added to local catalogue .... etc


CT VOC WED
VOC WED
1: V
2: CS
3: ../accuterm/FTBP.OUT/WED

WED VOC LOGIN now works fine ...

I'll check this in UV tomorrow, and post the results here.

Cheers,

Brian
Back to Top
Shrek59 View Drop Down
Senior Member
Senior Member


Joined: December 04 2006
Location: New Zealand
Status: Offline
Points: 196
Post Options Post Options   Thanks (0) Thanks(0)   Quote Shrek59 Quote  Post ReplyReply Direct Link To This Post Posted: December 15 2019 at 12:45pm
Hi Pete,

Tested this morning on a newly created UV account. No problems encountered.

Cheers,

Brian
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.