Zumasys Homepage
Forum Home Forum Home > AccuTerm > Installation & Setup
  New Posts New Posts RSS Feed - 7.3 and 8.0 server-side updates
  FAQ FAQ  Forum Search   Register Register  Login Login

7.3 and 8.0 server-side updates

 Post Reply Post Reply
Author
Message
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Topic: 7.3 and 8.0 server-side updates
    Posted: September 07 2018 at 9:40am
The release notes for v7.3 do not tell us if it's recommended to update FTBP. I will assume not.

For 8.0:

It's always tough to get client and server software in sync. Load a few PCs with the new version and they might not work because the server needs to be updated. Update the server side and PCs still on the older release no longer work. We're forced to update all PCs as fast as possible. In the case of AccuTerm where there is no auto-update mechanism, that means the admin needs to do a lot of running around while some people aren't getting some work done.

So I'm really hoping the v8 FTBP first does a check for the client version, and then chains to code suitable for processing the request for that release. That would allow existing ACCUTERM accounts with FTBP to remain in place, unchanged, to be used by v7 clients until there are no more left, while a new ACCUTERM8 account is used by all v8 clients.

I can provide details for doing this if it would be helpful. If this isn't going to be built-in to v8, and the real point of all of this, please let us know so that I can prepare to do this on my client systems.

Thanks!
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
PSchellenbach View Drop Down
Admin Group
Admin Group

Moderator

Joined: December 15 2003
Location: United States
Status: Offline
Points: 2118
Post Options Post Options   Thanks (0) Thanks(0)   Quote PSchellenbach Quote  Post ReplyReply Direct Link To This Post Posted: September 21 2018 at 3:17pm
Hi Tony -

The design of the AccuTerm host programs has always been to ensure compatibility as much as possible, both backward and forward. It is entirely possible (but difficult to test now) that the current host programs will work perfectly with AccuTerm for DOS. It goes the other way too, AccuTerm 7 will work fine with AccuTerm 2000 host programs. There is a version handshake when any of the host programs start up. As you would imagine, using mismatched host programs and client version might reduce the features available, due to limitations of the older side.

Thanks,

Pete

Back to Top
TonyG View Drop Down
Beta Tester
Beta Tester


Joined: February 04 2004
Location: United States
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote TonyG Quote  Post ReplyReply Direct Link To This Post Posted: September 21 2018 at 4:29pm
Thanks bud. Yes, AccuTerm has always been good about interoperability. Given all the changes to the product, new people in the code, etc, I was just looking for some reassurance that v8 will be tested in cross-release environments.

I have one site for which I'm responsible in this area. I've just recently loaded the 7.3 client-side but have been hesitent to load 7.3 server components for fear of breaking the 7.1 and 7.2 users. At this moment I don't have a compelling reason to take that chance.

After 7.3 has been out a while I'll load up the server. They will continue to run 7.1 and 7.2 until we can get around the office to update them to 7.3.

The same pattern will be followed with 8.0. A couple client PCs first, pause, then server, pause, then all of the rest of the PCs ASAP. It's that transition process that concerns me. I don't want new clients to run on an old server, but it takes time to get around and we just don't want anything broken before we can get to all users.

My testing process will be to load v8 on my dev systems, and a separate ACCUTERM8 account, then have different accounts that use the v7 and v8 server accounts. I'll watch for issues and if everything is OK after a while I'll recommend a transition for users.

If, when v8 is out, you can verify that these v7/v8 combos have already been well tested, I'd feel a lot better about recommending upgrades to clients and colleagues.

Best to ya.
T
Tony Gravagno Nebula Research & Development
TG@ Nebula-RnD . com
http://Nebula-RnD.com/blog
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms
https://www.linkedin.com/groups/64935
Back to Top
Lobbos View Drop Down
Newbie
Newbie
Avatar

Joined: May 20 2019
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lobbos Quote  Post ReplyReply Direct Link To This Post Posted: May 21 2019 at 7:24am
Do you foresee any issues with 8.0?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.